Pim, pam, pum… Promethean i els nous kernels fan bum!

Benvinguts una altra vegada a aquest circ de tres pistes anomenat “Linkat a la Trinxera” on el seu segur servidor es deixa tirar tartes de nata a la cara! (I així no veuen què faig amb els seus peus Jejejjejejejejeje).

Després d’haver confiat cegament en Promethean, pissarres digitals que ens havien salvat dels instal·ladors tancats d’Interwrite (sí, a Línux també hi ha software sense el codi font i no penso ara posar-me a discutir sobre el Software Lliure, el codi font i altres coses, deixem-ho per un altre dia) hem trobat la primera pega greu (la dels 64 bits, ja fa temps, era un detall menor). El plantejament de la situació és aquest:

Sempre fem els possibles per fer funcionar la maquinària amb el kernel més avançat possible per aprofitar-les al màxim. En aquest cas, i per deixar-ho clar, treballem amb tres nuclis:

Kernel 3.12: bàsic de Ubuntu 14.04.

Kernel 3.16: Ubuntu 14.10. Disponible a la 14.04 tot activant el repositori trusty-proposed.

Kernel 3.17.pf: Compilat pels amics d’Ubuntu León (aquí y aquí). Una meravella de rendiment que, amb quatre ajustos fa volar fins i tot els teòricaments abandonats i morts Pentium IV amb un modest 1’5 GB de RAM. Les gràfiques fan el que poden, però quant a la resta… bé, la Vella Guàrdia torna a l’assalt des dels magatzems on els volien condemnar a mort entre la pols. Algú ha pensat en una sala amb deu ordinadors a plena potència per la espantosa, inassumible i descontrolada quantitat de vuit-cents euros?

Els clients normals, sense gestió de pissarra, van fantàsticament, però a les pissarres digitals ens apareix un greu problema. Misteriosament, sense motiu aparent, un dia els llapis deixen de funcionar.

Ja sabíem que els repositoris de Promethean van una distribució LTS per darrera (el precise va aparèixer quan es va obrir trusty, i fins llavors funcionàvem amb lucid), però fins ara havia funcionat. Ara no.

Una delimitació del problema portava a veure mitja llum al final del túnel. La placa de comunicació era reconeguda, es podia treballar amb la pissarra… amb el mouse. Heu provat mai d’escriure a una pissarra digital (o a una pantalla) amb el mouse? És moooooolt divertit. Per tant, només fallava la comunicació amb el llapis.

Proves, més proves, més proves,… esperar que Promethean actualitzés repositoris -ara, com abans, no tenen cap pressa-. Instal·lar el driver de la versió trusty que no es troba als repositoris de Promethean sinò a la wiki de la Linkat (aquí a 32 bits i aquí a 64bits). Res.

Finalment i com una bogeria més en una màquina que calia reinstal·lar… I si trèiem tots els nuclis menys el bàsic?

BANG! Premi. totes les crides al mòdul són correctes i la pissarra i el llapis funcionen perfectament. Tot i això, afegim un nova comprovació: Ara, ja en servei, tornem a pujar nucli (amb qualsevol dels dos)… I tornem a la situació inicial de malfuncionament.

Per tant, queda molt clar. Als clients ordinaris podem apurar la tecnologia fins al màxim, però als clients de pissarra, per ara, estem limitats als nuclis originals 3.12 -que ja funcionen prou bé, en realitat-.

També tenim l’opció b, es clar. Baixar les fonts i compilar; però això es una altra història i serà explicada en una altra ocasió.

Vale.

Anuncis
Aquesta entrada s'ha publicat en Hardware, Pissarres Promethean i etiquetada amb , , , , , . Afegiu a les adreces d'interès l'enllaç permanent.

Deixa un comentari

Fill in your details below or click an icon to log in:

WordPress.com Logo

Esteu comentant fent servir el compte WordPress.com. Log Out / Canvia )

Twitter picture

Esteu comentant fent servir el compte Twitter. Log Out / Canvia )

Facebook photo

Esteu comentant fent servir el compte Facebook. Log Out / Canvia )

Google+ photo

Esteu comentant fent servir el compte Google+. Log Out / Canvia )

Connecting to %s